Jump to content
Sign in to follow this  
Luke

Pokemon Go Bot - CrazyBot 1.7.7.8 VIP 2017/Mar/21

Recommended Posts

12 hours ago, pogogogo said:

If you "Show Package Contents" in the application itself on OS X, you can successfully launch the JAR file directly and it will open the application correctly. It won't load any settings, obviously, but it'll open (which is progress). 

However, if you go into the MacOS directory, and attempt to run the JavaAppLauncher, it gives the following stacktrace:


MacBook-Pro:~ user$ /Applications/CrazyBot-PokemonGO.app/Contents/MacOS/JavaAppLauncher ; exit;
log4j:ERROR Could not read configuration file [log4j.properties].
java.io.FileNotFoundException: log4j.properties (No such file or directory)
	at java.io.FileInputStream.open0(Native Method)
	at java.io.FileInputStream.open(FileInputStream.java:195)
	at java.io.FileInputStream.<init>(FileInputStream.java:138)
	at java.io.FileInputStream.<init>(FileInputStream.java:93)
	at org.apache.log4j.PropertyConfigurator.doConfigure(PropertyConfigurator.java:297)
	at org.apache.log4j.PropertyConfigurator.configure(PropertyConfigurator.java:315)
	at BotMain.<init>(BotMain.java:177)
	at BotMain.main(BotMain.java:755)
log4j:ERROR Ignoring configuration file [log4j.properties].
Exception in thread "main" java.lang.NullPointerException
	at a.d.o.<init>(PnlSettings.java:334)
	at BotMain.M(BotMain.java:398)
	at BotMain.<init>(BotMain.java:181)
	at BotMain.main(BotMain.java:755)

In prior versions of the application, the app would launch after the "Ignoring configuration file" error, but it seems you are relying on it in the current version somewhere, so it's throwing the null pointer.

I have a video of all of this uploading to Youtube now. I'll edit this post when it is up and add it.

Do you guys offer a Bug Bounty? :-P

 

issue confirmed. From now on, we would just release jar single file to both mac and win cross platform. VIP-365 promoted for Pogogogo! 

1.7.7.8.1 minor change for Mac will be released later today.

 

Share this post


Link to post
Share on other sites
On 2017/3/22 at 10:47 AM, pogogogo said:

Correct. 1.7.7.7 works. 1.7.7.8 introduced the problem.

Also, I just figured out the problem. One second. Assembling details. The issue is in the JavaAppLauncher

For mac can't open issue, we found the root cause. Just delete config file under  /Users/[USERNAME]/settings would fix it.

Share this post


Link to post
Share on other sites
9 hours ago, Luke said:

For mac can't open issue, we found the root cause. Just delete config file under  /Users/[USERNAME]/settings would fix it.

If you do that, the app will launch. However, running the app updates and recreates that settings config file. Once you close the app and try to restart it, the problem persists. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×